9516 C# Programming Manual: D:/9516/C# Directory Reference

9516 C# Programming Manual
  • D:
  • 9516
  • C#
C# Directory Reference

Files

file | AIAdvanced.cs
file | AIChannel.cs
file | AISignalExport.cs
file | AISync.cs
file | AITrigger.cs
file | JY9516AITask.cs
Generated by doxygen 1.9.1


9516 C# Programming Manual: D:/9516/C#/AIAdvanced.cs File Reference

Classes | Namespaces | Enumerations
AIAdvanced.cs File Reference

Classes

class | JY9516.AIAdvanced
Analog Input Advance Parameter Class More...
class | JY9516.BesselCompensation
Bessel Compensation Parameters More...

Namespaces

namespace JY9516

Enumerations

enum class | JY9516.ChoppingFrequency { JY9516.fMod32 = JY9516Import.JY9516_ADCChopping_fMod32 , JY9516.fMod8 = JY9516Import.JY9517_ADCChopping_fMod8 }
ADC Modulator Chopping Frequency Enum More...
enum class | JY9516.ADCFilterType { JY9516.WidebandLowRippleFilter = JY9516Import.WidebandLowRippleFilter , JY9516.Sinc5Filter = JY9516Import.Sinc5Filter }
ADC Filter Type Enum More...
enum class | JY9516.FilterMode { JY9516.Normal = 0 , JY9516.WideBandwidth = 1 }
Filter Mode More...


9516 C# Programming Manual: JY9516.AIAdvanced Class Reference

  • JY9516
  • AIAdvanced
Properties | List of all members
JY9516.AIAdvanced Class Reference

Analog Input Advance Parameter Class More...

Properties

ChoppingFrequency | ModulatorChoppingFrequency [get, set]
ADC Modulator Chopping Frequency More...
BesselCompensation | BesselCompensation [get]
Bessel Compensation Parameters More...
FilterMode | FilterMode [get, set]
Performance Mode More...

Detailed Description

Analog Input Advance Parameter Class

Property Documentation

◆ BesselCompensation

BesselCompensation JY9516.AIAdvanced.BesselCompensation
get

Bessel Compensation Parameters

◆ FilterMode

FilterMode JY9516.AIAdvanced.FilterMode
getset

Performance Mode

◆ ModulatorChoppingFrequency

ChoppingFrequency JY9516.AIAdvanced.ModulatorChoppingFrequency
getset

ADC Modulator Chopping Frequency

The documentation for this class was generated from the following file:
  • D:/9516/C#/AIAdvanced.cs


9516 C# Programming Manual: JY9516.BesselCompensation Class Reference

  • BesselCompensation
Properties | List of all members
JY9516.BesselCompensation Class Reference

Bessel Compensation Parameters More...

Properties

bool Enabled [get, set]
Enabled More...

Detailed Description

Bessel Compensation Parameters

Property Documentation

◆ Enabled

bool JY9516.BesselCompensation.Enabled
getset

Enabled

The documentation for this class was generated from the following file:
  • D:/9516/C#/AIAdvanced.cs


9516 C# Programming Manual: D:/9516/C#/AIChannel.cs File Reference

Classes | Namespaces | Enumerations
AIChannel.cs File Reference

Classes

class | JY9516.AIChannel
AI Channel More...
class | JY9516.EnumExtern

Namespaces

namespace JY9516

Enumerations

enum class JY9516.AIRange {
JY9516._10V = JY9516Import.JY9516_Range_10V , JY9516._5V = JY9516Import.JY9516_Range_5V , JY9516._2p5V = JY9516Import.JY9516_Range_2p5V , JY9516._1p25V = JY9516Import.JY9516_Range_1p25V ,
JY9516._0p625V = JY9516Import.JY9516_Range_0p625V , JY9516._0p3125V = JY9516Import.JY9516_Range_0p3125V
}
AI voltage range More...
enum class JY9516.Coupling { JY9516.AC = JY9516Import.JY9516_Coupling_AC , JY9516.DC = JY9516Import.JY9516_Coupling_DC }
Coupling More...


9516 C# Programming Manual: JY9516.AIChannel Class Reference

  • AIChannel
Properties | List of all members
JY9516.AIChannel Class Reference

AI Channel More...

Properties

int | ID [get]
Channel ID More...
double | RangeHigh [get]
Upper limit of range More...
double | RangeLow [get]
Lower limit of range More...
Coupling | Coupling [get]
Coupling More...
bool | IEPEEnabled [get]
IEPE enabled More...
AIRange | Range [get]
Input voltage range(grade) More...
double | RawDataScaleFactor [get]
This fator is used to convert RawData(binary) to Data(voltage in V). More...

Detailed Description

AI Channel

Property Documentation

◆ Coupling

Coupling JY9516.AIChannel.Coupling
get

Coupling

◆ ID

int JY9516.AIChannel.ID
get

Channel ID

◆ IEPEEnabled

bool JY9516.AIChannel.IEPEEnabled
get

IEPE enabled

◆ Range

AIRange JY9516.AIChannel.Range
get

Input voltage range(grade)

◆ RangeHigh

double JY9516.AIChannel.RangeHigh
get

Upper limit of range

◆ RangeLow

double JY9516.AIChannel.RangeLow
get

Lower limit of range

◆ RawDataScaleFactor

double JY9516.AIChannel.RawDataScaleFactor
get

This fator is used to convert RawData(binary) to Data(voltage in V).

RawData * factor = Data

The documentation for this class was generated from the following file:
  • D:/9516/C#/AIChannel.cs


9516 C# Programming Manual: D:/9516/C#/AISignalExport.cs File Reference

Classes | Namespaces | Enumerations
AISignalExport.cs File Reference

Classes

class JY9516.AISignalExport
AI Signal Export Class More...

Namespaces

namespace JY9516

Enumerations

enum class JY9516.AISignalExportSource {
JY9516.SampleClock = JY9516Import.JY9516_EXPORT_SAMPLE_CLOCK , JY9516.Sync = JY9516Import.JY9516_EXPORT_SYNC_ENABLE , JY9516.ReadyForTrig = JY9516Import.JY9516_EXPORT_RX_READY_FOR_REF_TRIG , JY9516.Trig = JY9516Import.JY9516_EXPORT_RX_REF_TRIG ,
JY9516.EndOfRecord = JY9516Import.JY9516_EXPORT_RX_END_OF_RECORD , JY9516.EndOfAcquisition = JY9516Import.JY9516_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum More...
enum class JY9516.SignalExportDestination {
JY9516.Ext_Trig = JY9516Import.JY9516_DigitalTriggerSource_External , JY9516.PXI_Trig0 = JY9516Import.JY9516_DigitalTriggerSource_BUS_0 , JY9516.PXI_Trig1 = JY9516Import.JY9516_DigitalTriggerSource_BUS_1 , JY9516.PXI_Trig2 = JY9516Import.JY9516_DigitalTriggerSource_BUS_2 ,
JY9516.PXI_Trig3 = JY9516Import.JY9516_DigitalTriggerSource_BUS_3 , JY9516.PXI_Trig4 = JY9516Import.JY9516_DigitalTriggerSource_BUS_4 , JY9516.PXI_Trig5 = JY9516Import.JY9516_DigitalTriggerSource_BUS_5 , JY9516.PXI_Trig6 = JY9516Import.JY9516_DigitalTriggerSource_BUS_6 ,
JY9516.PXI_Trig7 = JY9516Import.JY9516_DigitalTriggerSource_BUS_7 , JY9516.PXI_Star = JY9516Import.JY9516_DigitalTriggerSource_STAR
}
Signal Export Destination Enum More...


9516 C# Programming Manual: JY9516.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9516.AISignalExport Class Reference

AI Signal Export Class More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one signal to desination. More...
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one signal to mutil desinations. More...
void | Clear (SignalExportDestination destination)
Clear one signal export More...
void | ClearAll ()
Clear all signal export. More...

Detailed Description

AI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY9516.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one signal to mutil desinations.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY9516.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one signal to desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY9516.AISignalExport.Clear ( SignalExportDestination destination )

Clear one signal export

Parameters
destination Export Desination

◆ ClearAll()

void JY9516.AISignalExport.ClearAll ( )

Clear all signal export.

The documentation for this class was generated from the following file:
  • D:/9516/C#/AISignalExport.cs


9516 C# Programming Manual: D:/9516/C#/AISync.cs File Reference

Classes | Namespaces | Enumerations
AISync.cs File Reference

Classes

class JY9516.Sync

Namespaces

namespace JY9516

Enumerations

enum class JY9516.SyncTopology { JY9516.Independent = JY9516Import.JY9516_SyncMode_Sole , JY9516.Master = JY9516Import.JY9516_SyncMode_Master , JY9516.Slave = JY9516Import.JY9516_SyncMode_Slave }
Multi-Device Sync Topology More...
enum class JY9516.SyncTriggerTerminal {
JY9516.Ext_Trig = JY9516Import.JY9516_DigitalTriggerSource_External , JY9516.PXI_Trig0 = JY9516Import.JY9516_DigitalTriggerSource_BUS_0 , JY9516.PXI_Trig1 = JY9516Import.JY9516_DigitalTriggerSource_BUS_1 , JY9516.PXI_Trig2 = JY9516Import.JY9516_DigitalTriggerSource_BUS_2 ,
JY9516.PXI_Trig3 = JY9516Import.JY9516_DigitalTriggerSource_BUS_3 , JY9516.PXI_Trig4 = JY9516Import.JY9516_DigitalTriggerSource_BUS_4 , JY9516.PXI_Trig5 = JY9516Import.JY9516_DigitalTriggerSource_BUS_5 , JY9516.PXI_Trig6 = JY9516Import.JY9516_DigitalTriggerSource_BUS_6 ,
JY9516.PXI_Trig7 = JY9516Import.JY9516_DigitalTriggerSource_BUS_7 , JY9516.PXI_Star = JY9516Import.JY9516_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...


9516 C# Programming Manual: JY9516.Sync Class Reference

  • Sync
Properties | List of all members
JY9516.Sync Class Reference

More...

Properties

SyncTopology | Topology [get, set]
Sync Topology Configuration. More...
SyncTriggerTerminal | TriggerRoutingTerminal [get, set]
Sync Trigger Signal Routing Terminal. More...
bool | Synchronized [get]
This device has bee synchronized. More...

Detailed Description

同步配置类

Sync Configuration Class

Property Documentation

◆ Synchronized

bool JY9516.Sync.Synchronized
get

This device has bee synchronized.

◆ Topology

SyncTopology JY9516.Sync.Topology
getset

Sync Topology Configuration.

The default value is SyncTopology.Independent.

◆ TriggerRoutingTerminal

SyncTriggerTerminal JY9516.Sync.TriggerRoutingTerminal
getset

Sync Trigger Signal Routing Terminal.

The documentation for this class was generated from the following file:
  • D:/9516/C#/AISync.cs


9516 C# Programming Manual: D:/9516/C#/AITrigger.cs File Reference

Classes | Namespaces | Enumerations
AITrigger.cs File Reference

Classes

class | JY9516.AIDigitalTrigger
AI Digital trigger params. More...
class | JY9516.AIAnalogTrigger
AI Analog Trigger More...
class | JY9516.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator More...
class | JY9516.AIAnalogWindowComparator
AI Analog Window Comparator More...
class | JY9516.AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | JY9516.AITrigger
AI Trigger params More...

Namespaces

namespace JY9516

Enumerations

enum class | JY9516.AITriggerMode { JY9516.Start , JY9516.Reference }
AI trigger mode enum type. More...
enum class | JY9516.AITriggerType { JY9516.Immediately = JY9516Import.JY9516_TriggerType_Immediately , JY9516.Digital = JY9516Import.JY9516_TriggerType_Digital , JY9516.Software = JY9516Import.JY9516_TriggerType_Software , JY9516.Analog = JY9516Import.JY9516_TriggerType_Analog }
AI trigger type enum type. More...
enum class JY9516.AIDigitalTriggerSource {
JY9516.Ext_Trig = JY9516Import.JY9516_DigitalTriggerSource_External , JY9516.PXI_Trig0 = JY9516Import.JY9516_DigitalTriggerSource_BUS_0 , JY9516.PXI_Trig1 = JY9516Import.JY9516_DigitalTriggerSource_BUS_1 , JY9516.PXI_Trig2 = JY9516Import.JY9516_DigitalTriggerSource_BUS_2 ,
JY9516.PXI_Trig3 = JY9516Import.JY9516_DigitalTriggerSource_BUS_3 , JY9516.PXI_Trig4 = JY9516Import.JY9516_DigitalTriggerSource_BUS_4 , JY9516.PXI_Trig5 = JY9516Import.JY9516_DigitalTriggerSource_BUS_5 , JY9516.PXI_Trig6 = JY9516Import.JY9516_DigitalTriggerSource_BUS_6 ,
JY9516.PXI_Trig7 = JY9516Import.JY9516_DigitalTriggerSource_BUS_7 , JY9516.PXI_Star = JY9516Import.JY9516_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | JY9516.AIDigitalTriggerEdge { JY9516.Rising = JY9516Import.JY9516_DigitalTriggerEdge_Rising , JY9516.Falling = JY9516Import.JY9516_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum class JY9516.AIAnalogTriggerSource {
JY9516.Channel_0 , JY9516.Channel_1 , JY9516.Channel_2 , JY9516.Channel_3 ,
JY9516.Channel_4 , JY9516.Channel_5 , JY9516.Channel_6 , JY9516.Channel_7 ,
JY9516.Channel_8 , JY9516.Channel_9 , JY9516.Channel_10 , JY9516.Channel_11 ,
JY9516.Channel_12 , JY9516.Channel_13 , JY9516.Channel_14 , JY9516.Channel_15
}
AI Analog Trigger Source More...
enum class | JY9516.AIAnalogTriggerComparator { JY9516.Edge , JY9516.Hysteresis , JY9516.Window }
AI Analog Trigger Comparator More...
enum class | JY9516.AIAnalogTriggerEdge { JY9516.Rising , JY9516.Falling }
AI Analog Trigger Edge More...
enum class | JY9516.AIAnalogWindowCondition { JY9516.Entering , JY9516.Leaving }
AI Analog Window Trigger Condition More...


9516 C# Programming Manual: JY9516.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY9516.AIDigitalTrigger Class Reference

AI Digital trigger params. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI digital trigger source. More...
AIDigitalTriggerEdge | Edge [get, set]
AI digital trigger effective edge. More...

Detailed Description

AI Digital trigger params.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY9516.AIDigitalTrigger.Edge
getset

AI digital trigger effective edge.

◆ Source

AIDigitalTriggerSource JY9516.AIDigitalTrigger.Source
getset

AI digital trigger source.

The documentation for this class was generated from the following file:
  • D:/9516/C#/AITrigger.cs


9516 C# Programming Manual: JY9516.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY9516.AIAnalogTrigger Class Reference

AI Analog Trigger More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source More...
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator More...
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator More...
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr More...
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr More...

Detailed Description

AI Analog Trigger

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY9516.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator

◆ Edge

AIAnalogEdgeComparator JY9516.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator

◆ Hysteresis

AIAnalogHysteresisComparator JY9516.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr

◆ Source

AIAnalogTriggerSource JY9516.AIAnalogTrigger.Source
getset

Analog Trigger source

◆ Window

AIAnalogWindowComparator JY9516.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr

The documentation for this class was generated from the following file:
  • D:/9516/C#/AITrigger.cs


9516 C# Programming Manual: JY9516.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY9516.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Hysteresis Comparator

Member Data Documentation

◆ HighThreshold

double JY9516.AIAnalogHysteresisComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY9516.AIAnalogHysteresisComparator.LowThreshold

Low Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9516.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • D:/9516/C#/AITrigger.cs


9516 C# Programming Manual: JY9516.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY9516.AIAnalogWindowComparator Class Reference

AI Analog Window Comparator More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition More...

Detailed Description

AI Analog Window Comparator

Member Data Documentation

◆ HighThreshold

double JY9516.AIAnalogWindowComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY9516.AIAnalogWindowComparator.LowThreshold

Low Threshold

Property Documentation

◆ Condition

AIAnalogWindowCondition JY9516.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition

The documentation for this class was generated from the following file:
  • D:/9516/C#/AITrigger.cs


9516 C# Programming Manual: JY9516.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY9516.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator More...

Public Attributes

double Threshold
Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Edge Comparator

Member Data Documentation

◆ Threshold

double JY9516.AIAnalogEdgeComparator.Threshold

Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9516.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • D:/9516/C#/AITrigger.cs


9516 C# Programming Manual: JY9516.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY9516.AITrigger Class Reference

AI Trigger params More...

Properties

AITriggerType | Type [get, set]
AI trigger type. More...
AITriggerMode | Mode [get, set]
AI trigger mode. More...
AIDigitalTrigger | Digital [get]
AI digital trigger params. More...
AIAnalogTrigger | Analog [get]
AI analog trigger params. More...
int | ReTriggerCount [get, set]
Number of repeat triggers. More...
uint | PreTriggerSamples [get, set]
AI pretrigger points. More...

Detailed Description

AI Trigger params

Property Documentation

◆ Analog

AIAnalogTrigger JY9516.AITrigger.Analog
get

AI analog trigger params.

◆ Digital

AIDigitalTrigger JY9516.AITrigger.Digital
get

AI digital trigger params.

◆ Mode

AITriggerMode JY9516.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY9516.AITrigger.PreTriggerSamples
getset

AI pretrigger points.

Only valid in the reference trigger mode.

◆ ReTriggerCount

int JY9516.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

No repeat the trigger when 0 or 1, or the number of repeated triggers.

◆ Type

AITriggerType JY9516.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/9516/C#/AITrigger.cs


9516 C# Programming Manual: D:/9516/C#/JY9516AITask.cs File Reference

Classes | Namespaces | Enumerations
JY9516AITask.cs File Reference

Classes

class | JY9516.JY9516AITask
JY9516 AI Task More...
class | JY9516.ConversionStatus
ADC Convesion Status Class More...

Namespaces

namespace JY9516

Enumerations

enum class | JY9516.AIMode { JY9516.Finite = JY9516Import.JY9516_AI_Finite , JY9516.Continuous = JY9516Import.JY9516_AI_Continuous , JY9516.Single = JY9516Import.JY9516_AI_Single }
AI mode enum type More...
enum class JY9516.SamplingState {
JY9516.Idle = 1 << 0 , JY9516.WaitingForStart = 1 << 1 , JY9516.PreSampling = 1 << 2 , JY9516.WaitingForRefTrigger = 1 << 3 ,
JY9516.PostSampling = 1 << 4 , JY9516.RecordCompleted = 1 << 5 , JY9516.WaitingForAdvanceTrigger = 1 << 6 , JY9516.Done = 1 << 7
}
Sampling State Enum More...
enum class | JY9516.IEPEConnectionStatus { JY9516.Normal = 0 , JY9516.OpenCircuit = 1 , JY9516.ShortCircuit = 2 }
IEPE Connection Status More...


9516 C# Programming Manual: JY9516.JY9516AITask Class Reference

  • JY9516AITask
Public Member Functions | Properties | List of all members
JY9516.JY9516AITask Class Reference

JY9516 AI Task More...

Public Member Functions

JY9516AITask (int slotNumber)
Create a AI task with slot number. More...
JY9516AITask (string cardName)
Create a AI task with card name. More...
void | AddChannel (int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE)
Add one/all channel(s). More...
void | AddChannel (int chID, AIRange range, Coupling coupling, bool enableIEPE)
Add one/all channel(s). More...
void | RemoveChannel (int chID)
Delete the channel with the specified channel ID. More...
void | Commit ()
Commit current configuration. More...
void | Start ()
Start AI task. More...
void | Stop ()
Stop AI task. More...
void | StartSync ()
Start the multi-card synchronization process. More...
void | ReadRawData (ref int[] dataBuf, int samplesPerChannel, int timeout)
Read raw data and copy to buffer. More...
void | ReadRawData (ref int[] dataBuf, int timeout=-1)
Read raw data and copy to buffer. More...
void | ReadRawData (ref int[,] dataBuf, int samplesPerChannel, int timeout)
Read raw data by columns and copy to buffer. More...
void | ReadData (ref double[] dataBuf, int samplesPerChannel, int timeout)
Read data and copy to buffer. More...
void | ReadData (ref double[] dataBuf, int timeout=-1)
Read data and copy to buffer. More...
void | ReadData (ref double[,] dataBuf, int samplesPerChannel, int timeout)
Read data by columns and copy to buffer. More...
void | ReadData (ref double[,] dataBuf, int timeout=-1)
Read data by columns and copy to buffer. More...
void | ReadSinglePoint (ref double[] dataBuf)
Read one sample (per channel) in unbuffered reading to unmannaged buffer. More...
ConversionStatus[] GetConversionStatus ()
Get ADC conversion status on all enabled channels. More...
void | SendSoftwareTrigger ()
Send a software trigger. More...
Dictionary< int, IEPEConnectionStatus > | DetectIEPEConnection ()
Perform IEPE sensor connection status detection. More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...
bool | WaitUntilFilterSettled (int timeout=-1)
Waiting until the filter is settled. More...

Properties

JY9516Device | Device [get]
The device instance called by this AI task instance More...
List< AIChannel > | Channels [get]
List of enabled channels More...
AITrigger | Trigger [get]
AI trigger configuration More...
AISignalExport | SignalExport [get]
Signal export configuration More...
JY9516DAC | DAC [get]
DAC configuration More...
Sync | Sync [get]
Sync configuration More...
AIAdvanced | Advanced [get]
Advanced configuration More...
AIMode | Mode [get, set]
Sample mode More...
double | SampleRate [get, set]
Sampling rate per channel in Sa/s More...
int | SamplesToAcquire [get, set]
Samples to acquire More...
SamplingState | State [get]
Sampling state More...
UInt64 | AvailableSamples [get]
Number of samples per channel that can be read in the buffer. More...
UInt64 | TransferedSamples [get]
Number of points per channel that have already been read from the buffer. More...
bool | FilterSettled [get]
This property indicates whether the digital filter has been settled. More...
SampleInfo | SampleInfo [get]
Sampling information, about the process from modulation to data. More...
bool | DisableCalibration [get, set]
Calibration is disabled when this property is true. More...

Detailed Description

JY9516 AI Task

Constructor & Destructor Documentation

◆ JY9516AITask() [1/2]

JY9516.JY9516AITask.JY9516AITask ( int slotNumber )

Create a AI task with slot number.

Parameters
slotNumber Slot Number

◆ JY9516AITask() [2/2]

JY9516.JY9516AITask.JY9516AITask ( string cardName )

Create a AI task with card name.

Parameters
cardName Card Name

Member Function Documentation

◆ AddChannel() [1/2]

void JY9516.JY9516AITask.AddChannel | ( | int | chID,
 |  | AIRange | range,
 |  | Coupling | coupling,
 |  | bool | enableIEPE
 | ) |  |

Add one/all channel(s).

Parameters
chID | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [2/2]

void JY9516.JY9516AITask.AddChannel | ( | int | chID,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | bool | enableIEPE
 | ) |  |

Add one/all channel(s).

Parameters
chID | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ Commit()

void JY9516.JY9516AITask.Commit ( )

Commit current configuration.

Must be called before JY9516AITask.Start and JY9516AITask.StartSync if configuration changes.

◆ DetectIEPEConnection()

Dictionary<int, IEPEConnectionStatus> JY9516.JY9516AITask.DetectIEPEConnection ( )

Perform IEPE sensor connection status detection.

After calling this method, the device will output the excitation current and measure the voltage, and if the voltage is too large, it will be judged as an open circuit, and if the voltage is too small, it will be judged as a short circuit.

Returns
IEPE connection status. Dictionary's key is channel's ID.

◆ GetConversionStatus()

ConversionStatus [] JY9516.JY9516AITask.GetConversionStatus ( )

Get ADC conversion status on all enabled channels.

Returns
ADC conversion status.

◆ ReadData() [1/4]

void JY9516.JY9516AITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [2/4]

void JY9516.JY9516AITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | timeout = -1
 | ) |  |

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [3/4]

void JY9516.JY9516AITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [4/4]

void JY9516.JY9516AITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | timeout = -1
 | ) |  |

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/3]

void JY9516.JY9516AITask.ReadRawData | ( | ref int | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read raw data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/3]

void JY9516.JY9516AITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout = -1 keep waiting until finish.

◆ ReadRawData() [3/3]

void JY9516.JY9516AITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | timeout = -1
 | ) |  |

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadSinglePoint()

void JY9516.JY9516AITask.ReadSinglePoint ( ref double[] dataBuf )

Read one sample (per channel) in unbuffered reading to unmannaged buffer.

Parameters
dataBuf User buffer.

◆ RemoveChannel()

void JY9516.JY9516AITask.RemoveChannel ( int chID )

Delete the channel with the specified channel ID.

Parameters
chID Specified channel ID. chnId = -1: remove all channels.

◆ SendSoftwareTrigger()

void JY9516.JY9516AITask.SendSoftwareTrigger ( )

Send a software trigger.

Returns

◆ Start()

void JY9516.JY9516AITask.Start ( )

Start AI task.

◆ StartSync()

void JY9516.JY9516AITask.StartSync ( )

Start the multi-card synchronization process.

◆ Stop()

void JY9516.JY9516AITask.Stop ( )

Stop AI task.

◆ WaitUntilDone()

bool JY9516.JY9516AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Only valid when Mode is AIMode.Finite.

Parameters
timeout Wait timeout in ms, or never times out when value is -1.
Returns
Whether the task has been completed

◆ WaitUntilFilterSettled()

bool JY9516.JY9516AITask.WaitUntilFilterSettled ( int timeout = -1 )

Waiting until the filter is settled.

Due to the weighting of the digital filters, there is a delay from the first conversion to fully settled data after commit or synchronization.

Parameters
timeout Wait timeout in ms, or never times out when value is -1.
Returns
Whether the filter has been settled.

Property Documentation

◆ Advanced

AIAdvanced JY9516.JY9516AITask.Advanced
get

Advanced configuration

◆ AvailableSamples

UInt64 JY9516.JY9516AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ Channels

List<AIChannel> JY9516.JY9516AITask.Channels
get

List of enabled channels

◆ DAC

JY9516DAC JY9516.JY9516AITask.DAC
get

DAC configuration

◆ Device

JY9516Device JY9516.JY9516AITask.Device
get

The device instance called by this AI task instance

◆ DisableCalibration

bool JY9516.JY9516AITask.DisableCalibration
getset

Calibration is disabled when this property is true.

The default value is false.

◆ FilterSettled

bool JY9516.JY9516AITask.FilterSettled
get

This property indicates whether the digital filter has been settled.

Due to the weighting of the digital filters, there is a delay from the first conversion to fully settled data after commit or synchronization.

◆ Mode

AIMode JY9516.JY9516AITask.Mode
getset

Sample mode

◆ SampleInfo

SampleInfo JY9516.JY9516AITask.SampleInfo
get

Sampling information, about the process from modulation to data.

◆ SampleRate

double JY9516.JY9516AITask.SampleRate
getset

Sampling rate per channel in Sa/s

◆ SamplesToAcquire

int JY9516.JY9516AITask.SamplesToAcquire
getset

Samples to acquire

◆ SignalExport

AISignalExport JY9516.JY9516AITask.SignalExport
get

Signal export configuration

◆ State

SamplingState JY9516.JY9516AITask.State
get

Sampling state

◆ Sync

Sync JY9516.JY9516AITask.Sync
get

Sync configuration

◆ TransferedSamples

UInt64 JY9516.JY9516AITask.TransferedSamples
get

Number of points per channel that have already been read from the buffer.

◆ Trigger

AITrigger JY9516.JY9516AITask.Trigger
get

AI trigger configuration

The documentation for this class was generated from the following file:
  • D:/9516/C#/JY9516AITask.cs


9516 C# Programming Manual: JY9516.ConversionStatus Class Reference

  • ConversionStatus
Properties | List of all members
JY9516.ConversionStatus Class Reference

ADC Convesion Status Class More...

Properties

bool | ErrorFlagged [get]
The error flagged bit indicates that a serious error has occurred. More...
bool | FilterSuturated [get]
The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale. More...
int | ChannelID [get]
The channel ID bits indicate the device channel from which the succeeding conversion status originates. More...

Detailed Description

ADC Convesion Status Class

Property Documentation

◆ ChannelID

int JY9516.ConversionStatus.ChannelID
get

The channel ID bits indicate the device channel from which the succeeding conversion status originates.

◆ ErrorFlagged

bool JY9516.ConversionStatus.ErrorFlagged
get

The error flagged bit indicates that a serious error has occurred.

This bit indicatesthat the external clock is not detected, a memory map bit has unexpectedly changed state, or an internal CRC error has been detected.

◆ FilterSuturated

bool JY9516.ConversionStatus.FilterSuturated
get

The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale.

The documentation for this class was generated from the following file:
  • D:/9516/C#/JY9516AITask.cs


9516 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9516 |
C AIAdvanced | Analog Input Advance Parameter Class
C BesselCompensation | Bessel Compensation Parameters
C AIChannel | AI Channel
C AISignalExport | AI Signal Export Class
C Sync |
C AIDigitalTrigger | AI Digital trigger params
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AITrigger | AI Trigger params
C JY9516AITask | JY9516 AI Task
C ConversionStatus | ADC Convesion Status Class


9516 C# Programming Manual: Member List

  • AIAdvanced
JY9516.AIAdvanced Member List

This is the complete list of members for JY9516.AIAdvanced, including all inherited members.

BesselCompensation | JY9516.AIAdvanced
FilterMode | JY9516.AIAdvanced
ModulatorChoppingFrequency | JY9516.AIAdvanced


9516 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9516.AIAnalogEdgeComparator Member List

This is the complete list of members for JY9516.AIAnalogEdgeComparator, including all inherited members.

Slope | JY9516.AIAnalogEdgeComparator
Threshold | JY9516.AIAnalogEdgeComparator


9516 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9516.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9516.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9516.AIAnalogHysteresisComparator
LowThreshold | JY9516.AIAnalogHysteresisComparator
Slope | JY9516.AIAnalogHysteresisComparator


9516 C# Programming Manual: Member List

  • AIAnalogTrigger
JY9516.AIAnalogTrigger Member List

This is the complete list of members for JY9516.AIAnalogTrigger, including all inherited members.

Comparator | JY9516.AIAnalogTrigger
Edge | JY9516.AIAnalogTrigger
Hysteresis | JY9516.AIAnalogTrigger
Source | JY9516.AIAnalogTrigger
Window | JY9516.AIAnalogTrigger


9516 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY9516.AIAnalogWindowComparator Member List

This is the complete list of members for JY9516.AIAnalogWindowComparator, including all inherited members.

Condition | JY9516.AIAnalogWindowComparator
HighThreshold | JY9516.AIAnalogWindowComparator
LowThreshold | JY9516.AIAnalogWindowComparator


9516 C# Programming Manual: Member List

  • AIChannel
JY9516.AIChannel Member List

This is the complete list of members for JY9516.AIChannel, including all inherited members.

Coupling | JY9516.AIChannel
ID | JY9516.AIChannel
IEPEEnabled | JY9516.AIChannel
Range | JY9516.AIChannel
RangeHigh | JY9516.AIChannel
RangeLow | JY9516.AIChannel
RawDataScaleFactor | JY9516.AIChannel


9516 C# Programming Manual: Member List

  • AIDigitalTrigger
JY9516.AIDigitalTrigger Member List

This is the complete list of members for JY9516.AIDigitalTrigger, including all inherited members.

Edge | JY9516.AIDigitalTrigger
Source | JY9516.AIDigitalTrigger


9516 C# Programming Manual: Member List

  • AISignalExport
JY9516.AISignalExport Member List

This is the complete list of members for JY9516.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9516.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY9516.AISignalExport
Clear(SignalExportDestination destination) | JY9516.AISignalExport
ClearAll() | JY9516.AISignalExport


9516 C# Programming Manual: Member List

  • AITrigger
JY9516.AITrigger Member List

This is the complete list of members for JY9516.AITrigger, including all inherited members.

Analog | JY9516.AITrigger
Digital | JY9516.AITrigger
Mode | JY9516.AITrigger
PreTriggerSamples | JY9516.AITrigger
ReTriggerCount | JY9516.AITrigger
Type | JY9516.AITrigger


9516 C# Programming Manual: Member List

  • BesselCompensation
JY9516.BesselCompensation Member List

This is the complete list of members for JY9516.BesselCompensation, including all inherited members.

Enabled JY9516.BesselCompensation


9516 C# Programming Manual: Member List

  • ConversionStatus
JY9516.ConversionStatus Member List

This is the complete list of members for JY9516.ConversionStatus, including all inherited members.

ChannelID | JY9516.ConversionStatus
ErrorFlagged | JY9516.ConversionStatus
FilterSuturated | JY9516.ConversionStatus


9516 C# Programming Manual: Member List

  • JY9516AITask
JY9516.JY9516AITask Member List

This is the complete list of members for JY9516.JY9516AITask, including all inherited members.

AddChannel(int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE) | JY9516.JY9516AITask
AddChannel(int chID, AIRange range, Coupling coupling, bool enableIEPE) | JY9516.JY9516AITask
Advanced | JY9516.JY9516AITask
AvailableSamples | JY9516.JY9516AITask
Channels | JY9516.JY9516AITask
Commit() | JY9516.JY9516AITask
DAC | JY9516.JY9516AITask
DetectIEPEConnection() | JY9516.JY9516AITask
Device | JY9516.JY9516AITask
DisableCalibration | JY9516.JY9516AITask
FilterSettled | JY9516.JY9516AITask
GetConversionStatus() | JY9516.JY9516AITask
JY9516AITask(int slotNumber) | JY9516.JY9516AITask
JY9516AITask(string cardName) | JY9516.JY9516AITask
Mode | JY9516.JY9516AITask
ReadData(ref double[] dataBuf, int samplesPerChannel, int timeout) | JY9516.JY9516AITask
ReadData(ref double[] dataBuf, int timeout=-1) | JY9516.JY9516AITask
ReadData(ref double[,] dataBuf, int samplesPerChannel, int timeout) | JY9516.JY9516AITask
ReadData(ref double[,] dataBuf, int timeout=-1) | JY9516.JY9516AITask
ReadRawData(ref int[] dataBuf, int samplesPerChannel, int timeout) | JY9516.JY9516AITask
ReadRawData(ref int[] dataBuf, int timeout=-1) | JY9516.JY9516AITask
ReadRawData(ref int[,] dataBuf, int samplesPerChannel, int timeout) | JY9516.JY9516AITask
ReadSinglePoint(ref double[] dataBuf) | JY9516.JY9516AITask
RemoveChannel(int chID) | JY9516.JY9516AITask
SampleInfo | JY9516.JY9516AITask
SampleRate | JY9516.JY9516AITask
SamplesToAcquire | JY9516.JY9516AITask
SendSoftwareTrigger() | JY9516.JY9516AITask
SignalExport | JY9516.JY9516AITask
Start() | JY9516.JY9516AITask
StartSync() | JY9516.JY9516AITask
State | JY9516.JY9516AITask
Stop() | JY9516.JY9516AITask
Sync | JY9516.JY9516AITask
TransferedSamples | JY9516.JY9516AITask
Trigger | JY9516.JY9516AITask
WaitUntilDone(int timeout=-1) | JY9516.JY9516AITask
WaitUntilFilterSettled(int timeout=-1) | JY9516.JY9516AITask


9516 C# Programming Manual: Member List

  • Sync
JY9516.Sync Member List

This is the complete list of members for JY9516.Sync, including all inherited members.

Synchronized | JY9516.Sync
Topology | JY9516.Sync
TriggerRoutingTerminal | JY9516.Sync


9516 C# Programming Manual: Class Index

Class Index
A | B | C | J | S
A
AIAdvanced (JY9516)
AIAnalogEdgeComparator (JY9516)
AIAnalogHysteresisComparator (JY9516)
AIAnalogTrigger (JY9516)
AIAnalogWindowComparator (JY9516)
AIChannel (JY9516)
AIDigitalTrigger (JY9516)
AISignalExport (JY9516)
AITrigger (JY9516)
B
BesselCompensation (JY9516)
C
ConversionStatus (JY9516)
J
JY9516AITask (JY9516)
S
Sync (JY9516)


9516 C# Programming Manual: D:/9516 Directory Reference

  • D:
  • 9516
9516 Directory Reference

Directories

directory C#


9516 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 9516


9516 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 9516
▼ C#
AIAdvanced.cs
AIChannel.cs
AISignalExport.cs
AISync.cs
AITrigger.cs
JY9516AITask.cs


9516 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY9516.AISignalExport
  • AddChannel() : JY9516.JY9516AITask
  • Advanced : JY9516.JY9516AITask
  • Analog : JY9516.AITrigger
  • AvailableSamples : JY9516.JY9516AITask

- b -

  • BesselCompensation : JY9516.AIAdvanced

- c -

  • ChannelID : JY9516.ConversionStatus
  • Channels : JY9516.JY9516AITask
  • Clear() : JY9516.AISignalExport
  • ClearAll() : JY9516.AISignalExport
  • Commit() : JY9516.JY9516AITask
  • Comparator : JY9516.AIAnalogTrigger
  • Condition : JY9516.AIAnalogWindowComparator
  • Coupling : JY9516.AIChannel

- d -

  • DAC : JY9516.JY9516AITask
  • DetectIEPEConnection() : JY9516.JY9516AITask
  • Device : JY9516.JY9516AITask
  • Digital : JY9516.AITrigger
  • DisableCalibration : JY9516.JY9516AITask

- e -

  • Edge : JY9516.AIAnalogTrigger , JY9516.AIDigitalTrigger
  • Enabled : JY9516.BesselCompensation
  • ErrorFlagged : JY9516.ConversionStatus

- f -

  • FilterMode : JY9516.AIAdvanced
  • FilterSettled : JY9516.JY9516AITask
  • FilterSuturated : JY9516.ConversionStatus

- g -

  • GetConversionStatus() : JY9516.JY9516AITask

- h -

  • HighThreshold : JY9516.AIAnalogHysteresisComparator , JY9516.AIAnalogWindowComparator
  • Hysteresis : JY9516.AIAnalogTrigger

- i -

  • ID : JY9516.AIChannel
  • IEPEEnabled : JY9516.AIChannel

- j -

  • JY9516AITask() : JY9516.JY9516AITask

- l -

  • LowThreshold : JY9516.AIAnalogHysteresisComparator , JY9516.AIAnalogWindowComparator

- m -

  • Mode : JY9516.AITrigger , JY9516.JY9516AITask
  • ModulatorChoppingFrequency : JY9516.AIAdvanced

- p -

  • PreTriggerSamples : JY9516.AITrigger

- r -

  • Range : JY9516.AIChannel
  • RangeHigh : JY9516.AIChannel
  • RangeLow : JY9516.AIChannel
  • RawDataScaleFactor : JY9516.AIChannel
  • ReadData() : JY9516.JY9516AITask
  • ReadRawData() : JY9516.JY9516AITask
  • ReadSinglePoint() : JY9516.JY9516AITask
  • RemoveChannel() : JY9516.JY9516AITask
  • ReTriggerCount : JY9516.AITrigger

- s -

  • SampleInfo : JY9516.JY9516AITask
  • SampleRate : JY9516.JY9516AITask
  • SamplesToAcquire : JY9516.JY9516AITask
  • SendSoftwareTrigger() : JY9516.JY9516AITask
  • SignalExport : JY9516.JY9516AITask
  • Slope : JY9516.AIAnalogEdgeComparator , JY9516.AIAnalogHysteresisComparator
  • Source : JY9516.AIAnalogTrigger , JY9516.AIDigitalTrigger
  • Start() : JY9516.JY9516AITask
  • StartSync() : JY9516.JY9516AITask
  • State : JY9516.JY9516AITask
  • Stop() : JY9516.JY9516AITask
  • Sync : JY9516.JY9516AITask
  • Synchronized : JY9516.Sync

- t -

  • Threshold : JY9516.AIAnalogEdgeComparator
  • Topology : JY9516.Sync
  • TransferedSamples : JY9516.JY9516AITask
  • Trigger : JY9516.JY9516AITask
  • TriggerRoutingTerminal : JY9516.Sync
  • Type : JY9516.AITrigger

- w -

  • WaitUntilDone() : JY9516.JY9516AITask
  • WaitUntilFilterSettled() : JY9516.JY9516AITask
  • Window : JY9516.AIAnalogTrigger


9516 C# Programming Manual: Class Members - Functions

  • Add() : JY9516.AISignalExport
  • AddChannel() : JY9516.JY9516AITask
  • Clear() : JY9516.AISignalExport
  • ClearAll() : JY9516.AISignalExport
  • Commit() : JY9516.JY9516AITask
  • DetectIEPEConnection() : JY9516.JY9516AITask
  • GetConversionStatus() : JY9516.JY9516AITask
  • JY9516AITask() : JY9516.JY9516AITask
  • ReadData() : JY9516.JY9516AITask
  • ReadRawData() : JY9516.JY9516AITask
  • ReadSinglePoint() : JY9516.JY9516AITask
  • RemoveChannel() : JY9516.JY9516AITask
  • SendSoftwareTrigger() : JY9516.JY9516AITask
  • Start() : JY9516.JY9516AITask
  • StartSync() : JY9516.JY9516AITask
  • Stop() : JY9516.JY9516AITask
  • WaitUntilDone() : JY9516.JY9516AITask
  • WaitUntilFilterSettled() : JY9516.JY9516AITask


9516 C# Programming Manual: Class Members - Properties

- a -

  • Advanced : JY9516.JY9516AITask
  • Analog : JY9516.AITrigger
  • AvailableSamples : JY9516.JY9516AITask

- b -

  • BesselCompensation : JY9516.AIAdvanced

- c -

  • ChannelID : JY9516.ConversionStatus
  • Channels : JY9516.JY9516AITask
  • Comparator : JY9516.AIAnalogTrigger
  • Condition : JY9516.AIAnalogWindowComparator
  • Coupling : JY9516.AIChannel

- d -

  • DAC : JY9516.JY9516AITask
  • Device : JY9516.JY9516AITask
  • Digital : JY9516.AITrigger
  • DisableCalibration : JY9516.JY9516AITask

- e -

  • Edge : JY9516.AIAnalogTrigger , JY9516.AIDigitalTrigger
  • Enabled : JY9516.BesselCompensation
  • ErrorFlagged : JY9516.ConversionStatus

- f -

  • FilterMode : JY9516.AIAdvanced
  • FilterSettled : JY9516.JY9516AITask
  • FilterSuturated : JY9516.ConversionStatus

- h -

  • Hysteresis : JY9516.AIAnalogTrigger

- i -

  • ID : JY9516.AIChannel
  • IEPEEnabled : JY9516.AIChannel

- m -

  • Mode : JY9516.AITrigger , JY9516.JY9516AITask
  • ModulatorChoppingFrequency : JY9516.AIAdvanced

- p -

  • PreTriggerSamples : JY9516.AITrigger

- r -

  • Range : JY9516.AIChannel
  • RangeHigh : JY9516.AIChannel
  • RangeLow : JY9516.AIChannel
  • RawDataScaleFactor : JY9516.AIChannel
  • ReTriggerCount : JY9516.AITrigger

- s -

  • SampleInfo : JY9516.JY9516AITask
  • SampleRate : JY9516.JY9516AITask
  • SamplesToAcquire : JY9516.JY9516AITask
  • SignalExport : JY9516.JY9516AITask
  • Slope : JY9516.AIAnalogEdgeComparator , JY9516.AIAnalogHysteresisComparator
  • Source : JY9516.AIAnalogTrigger , JY9516.AIDigitalTrigger
  • State : JY9516.JY9516AITask
  • Sync : JY9516.JY9516AITask
  • Synchronized : JY9516.Sync

- t -

  • Topology : JY9516.Sync
  • TransferedSamples : JY9516.JY9516AITask
  • Trigger : JY9516.JY9516AITask
  • TriggerRoutingTerminal : JY9516.Sync
  • Type : JY9516.AITrigger

- w -

  • Window : JY9516.AIAnalogTrigger


9516 C# Programming Manual: Class Members - Variables

  • HighThreshold : JY9516.AIAnalogHysteresisComparator , JY9516.AIAnalogWindowComparator
  • LowThreshold : JY9516.AIAnalogHysteresisComparator , JY9516.AIAnalogWindowComparator
  • Threshold : JY9516.AIAnalogEdgeComparator


9516 C# Programming Manual: Main Page

9516 C# Programming Manual Documentation


9516 C# Programming Manual: JY9516 Namespace Reference

Classes | Enumerations
JY9516 Namespace Reference

Classes

class | AIAdvanced
Analog Input Advance Parameter Class More...
class | BesselCompensation
Bessel Compensation Parameters More...
class | AIChannel
AI Channel More...
class | EnumExtern
class | AISignalExport
AI Signal Export Class More...
class | Sync
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AIAnalogTrigger
AI Analog Trigger More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator More...
class | AIAnalogWindowComparator
AI Analog Window Comparator More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | AITrigger
AI Trigger params More...
class | JY9516AITask
JY9516 AI Task More...
class | ConversionStatus
ADC Convesion Status Class More...

Enumerations

enum class | ChoppingFrequency { fMod32 = JY9516Import.JY9516_ADCChopping_fMod32 , fMod8 = JY9516Import.JY9517_ADCChopping_fMod8 }
ADC Modulator Chopping Frequency Enum More...
enum class | ADCFilterType { WidebandLowRippleFilter = JY9516Import.WidebandLowRippleFilter , Sinc5Filter = JY9516Import.Sinc5Filter }
ADC Filter Type Enum More...
enum class | FilterMode { Normal = 0 , WideBandwidth = 1 }
Filter Mode More...
enum class AIRange {
_10V = JY9516Import.JY9516_Range_10V , _5V = JY9516Import.JY9516_Range_5V , _2p5V = JY9516Import.JY9516_Range_2p5V , _1p25V = JY9516Import.JY9516_Range_1p25V ,
_0p625V = JY9516Import.JY9516_Range_0p625V , _0p3125V = JY9516Import.JY9516_Range_0p3125V
}
AI voltage range More...
enum class | Coupling { AC = JY9516Import.JY9516_Coupling_AC , DC = JY9516Import.JY9516_Coupling_DC }
Coupling More...
enum class AISignalExportSource {
SampleClock = JY9516Import.JY9516_EXPORT_SAMPLE_CLOCK , Sync = JY9516Import.JY9516_EXPORT_SYNC_ENABLE , ReadyForTrig = JY9516Import.JY9516_EXPORT_RX_READY_FOR_REF_TRIG , Trig = JY9516Import.JY9516_EXPORT_RX_REF_TRIG ,
EndOfRecord = JY9516Import.JY9516_EXPORT_RX_END_OF_RECORD , EndOfAcquisition = JY9516Import.JY9516_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum More...
enum class SignalExportDestination {
Ext_Trig = JY9516Import.JY9516_DigitalTriggerSource_External , PXI_Trig0 = JY9516Import.JY9516_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516Import.JY9516_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516Import.JY9516_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516Import.JY9516_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516Import.JY9516_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516Import.JY9516_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516Import.JY9516_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516Import.JY9516_DigitalTriggerSource_BUS_7 , PXI_Star = JY9516Import.JY9516_DigitalTriggerSource_STAR
}
Signal Export Destination Enum More...
enum class | SyncTopology { Independent = JY9516Import.JY9516_SyncMode_Sole , Master = JY9516Import.JY9516_SyncMode_Master , Slave = JY9516Import.JY9516_SyncMode_Slave }
Multi-Device Sync Topology More...
enum class SyncTriggerTerminal {
Ext_Trig = JY9516Import.JY9516_DigitalTriggerSource_External , PXI_Trig0 = JY9516Import.JY9516_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516Import.JY9516_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516Import.JY9516_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516Import.JY9516_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516Import.JY9516_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516Import.JY9516_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516Import.JY9516_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516Import.JY9516_DigitalTriggerSource_BUS_7 , PXI_Star = JY9516Import.JY9516_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum class | AITriggerType { Immediately = JY9516Import.JY9516_TriggerType_Immediately , Digital = JY9516Import.JY9516_TriggerType_Digital , Software = JY9516Import.JY9516_TriggerType_Software , Analog = JY9516Import.JY9516_TriggerType_Analog }
AI trigger type enum type. More...
enum class AIDigitalTriggerSource {
Ext_Trig = JY9516Import.JY9516_DigitalTriggerSource_External , PXI_Trig0 = JY9516Import.JY9516_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516Import.JY9516_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516Import.JY9516_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516Import.JY9516_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516Import.JY9516_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516Import.JY9516_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516Import.JY9516_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516Import.JY9516_DigitalTriggerSource_BUS_7 , PXI_Star = JY9516Import.JY9516_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | AIDigitalTriggerEdge { Rising = JY9516Import.JY9516_DigitalTriggerEdge_Rising , Falling = JY9516Import.JY9516_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15
}
AI Analog Trigger Source More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition More...
enum class | AIMode { Finite = JY9516Import.JY9516_AI_Finite , Continuous = JY9516Import.JY9516_AI_Continuous , Single = JY9516Import.JY9516_AI_Single }
AI mode enum type More...
enum class SamplingState {
Idle = 1 << 0 , WaitingForStart = 1 << 1 , PreSampling = 1 << 2 , WaitingForRefTrigger = 1 << 3 ,
PostSampling = 1 << 4 , RecordCompleted = 1 << 5 , WaitingForAdvanceTrigger = 1 << 6 , Done = 1 << 7
}
Sampling State Enum More...
enum class | IEPEConnectionStatus { Normal = 0 , OpenCircuit = 1 , ShortCircuit = 2 }
IEPE Connection Status More...

Enumeration Type Documentation

◆ ADCFilterType

enum JY9516.ADCFilterType
strong

ADC Filter Type Enum

Enumerator
WidebandLowRippleFilter | Wideband low ripple filter, −3dB at 0.433 * SampleRate, with 34/SampleRate group delay. This filter has a flat pass band (±0.005 dB ripple) from dc to 102.4 kHz at 256 kSPS, from dc to 51.2 kHz at 128 kSPS, or from dc to 12.8 kHz at 32 kSPS
Sinc5Filter | Sinc5 low latency filter, −3dB at 0.204 * SampleRate, with 3/SampleRate group delay. This filter has a low latency path for low bandwidth, and low noise measurements.

◆ AIAnalogTriggerComparator

enum JY9516.AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator

Enumerator
Edge | Edge Comparator
Hysteresis | Hysteresis Comparator
Window | Window Comparator

◆ AIAnalogTriggerEdge

enum JY9516.AIAnalogTriggerEdge
strong

AI Analog Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIAnalogTriggerSource

enum JY9516.AIAnalogTriggerSource
strong

AI Analog Trigger Source

Enumerator
Channel_0 | Channel 0
Channel_1 | Channel 1
Channel_2 | Channel 2
Channel_3 | Channel 3
Channel_4 | Channel 4
Channel_5 | Channel 5
Channel_6 | Channel 6
Channel_7 | Channel 7
Channel_8 | Channel 8
Channel_9 | Channel 9
Channel_10 | Channel 10
Channel_11 | Channel 11
Channel_12 | Channel 12
Channel_13 | Channel 13
Channel_14 | Channel 14
Channel_15 | Channel 15

◆ AIAnalogWindowCondition

enum JY9516.AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition

Enumerator
Entering | Rising
Leaving | Falling

◆ AIDigitalTriggerEdge

enum JY9516.AIDigitalTriggerEdge
strong

AI digital trigger edge enum type.

Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ AIDigitalTriggerSource

enum JY9516.AIDigitalTriggerSource
strong

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger
PXI_Trig0 | PXI Trigger 0
PXI_Trig1 | PXI Trigger 1
PXI_Trig2 | PXI Trigger 2
PXI_Trig3 | PXI Trigger 3
PXI_Trig4 | PXI Trigger 4
PXI_Trig5 | PXI Trigger 5
PXI_Trig6 | PXI Trigger 6
PXI_Trig7 | PXI Trigger 7
PXI_Star | PXI Star

◆ AIMode

enum JY9516.AIMode
strong

AI mode enum type

Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.

◆ AIRange

enum JY9516.AIRange
strong

AI voltage range

Enumerator
_10V | ±10V
_5V | ±5V
_2p5V | ±2.5V
_1p25V | ±1.25V
_0p625V | ±0.625V
_0p3125V | ±0.3125V

◆ AISignalExportSource

enum JY9516.AISignalExportSource
strong

AI Signal Export Source Enum

Enumerator
SampleClock | AI Sample Clock
Sync | Sync Signal From Master to Slave(s)
ReadyForTrig | Ready for Trigger
Trig | Trigger Out
EndOfRecord | End of Record
EndOfAcquisition | End of Acquisition

◆ AITriggerMode

enum JY9516.AITriggerMode
strong

AI trigger mode enum type.

Enumerator
Start | Start trigger
Reference | Reference trigger. Only valid in the Finite mode.

◆ AITriggerType

enum JY9516.AITriggerType
strong

AI trigger type enum type.

Enumerator
Immediately | Immediately, no trigger.
Digital | Digital trigger.
Software | Software trigger.
Analog | Analog trigger.

◆ ChoppingFrequency

enum JY9516.ChoppingFrequency
strong

ADC Modulator Chopping Frequency Enum

Enumerator
fMod32 | chop at fMod/32
fMod8 | chop at fMod/8

◆ Coupling

enum JY9516.Coupling
strong

Coupling

Enumerator
AC | AC
DC | DC

◆ FilterMode

enum JY9516.FilterMode
strong

Filter Mode

Enumerator
Normal | Normal Mode. It has 0.4Fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s
WideBandwidth | Wide Bandwidth Mode. It has 0.4535Fs bandwidth, high latency, and a maximum sample rate of 128kSa/s

◆ IEPEConnectionStatus

enum JY9516.IEPEConnectionStatus
strong

IEPE Connection Status

Enumerator
Normal | Normal
OpenCircuit | Open circuit
ShortCircuit | Short circuit

◆ SamplingState

enum JY9516.SamplingState
strong

Sampling State Enum

Enumerator
Idle | Idle
WaitingForStart | Waiting for start trigger
PreSampling | Pre-sampling
WaitingForRefTrigger | Waiting for reference trigger
PostSampling | Post-sampling
RecordCompleted | Record completed
WaitingForAdvanceTrigger | Waiting for advance trigger
Done | Done

◆ SignalExportDestination

enum JY9516.SignalExportDestination
strong

Signal Export Destination Enum

Enumerator
Ext_Trig | External Trigger
PXI_Trig0 | PXI Trigger 0
PXI_Trig1 | PXI Trigger 1
PXI_Trig2 | PXI Trigger 2
PXI_Trig3 | PXI Trigger 3
PXI_Trig4 | PXI Trigger 4
PXI_Trig5 | PXI Trigger 5
PXI_Trig6 | PXI Trigger 6
PXI_Trig7 | PXI Trigger 7
PXI_Star | PXI Star

◆ SyncTopology

enum JY9516.SyncTopology
strong

Multi-Device Sync Topology

Enumerator
Independent | Independent.
Master | As the master device in the master-slave synchronization.
Slave | As the slave card in the master-slave synchronization.

◆ SyncTriggerTerminal

enum JY9516.SyncTriggerTerminal
strong

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger
PXI_Trig0 | PXI Trigger 0
PXI_Trig1 | PXI Trigger 1
PXI_Trig2 | PXI Trigger 2
PXI_Trig3 | PXI Trigger 3
PXI_Trig4 | PXI Trigger 4
PXI_Trig5 | PXI Trigger 5
PXI_Trig6 | PXI Trigger 6
PXI_Trig7 | PXI Trigger 7
PXI_Star | PXI Star


9516 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • ADCFilterType : JY9516
  • AIAnalogTriggerComparator : JY9516
  • AIAnalogTriggerEdge : JY9516
  • AIAnalogTriggerSource : JY9516
  • AIAnalogWindowCondition : JY9516
  • AIDigitalTriggerEdge : JY9516
  • AIDigitalTriggerSource : JY9516
  • AIMode : JY9516
  • AIRange : JY9516
  • AISignalExportSource : JY9516
  • AITriggerMode : JY9516
  • AITriggerType : JY9516
  • ChoppingFrequency : JY9516
  • Coupling : JY9516
  • FilterMode : JY9516
  • IEPEConnectionStatus : JY9516
  • SamplingState : JY9516
  • SignalExportDestination : JY9516
  • SyncTopology : JY9516
  • SyncTriggerTerminal : JY9516


9516 C# Programming Manual: Package Functions

  • ADCFilterType : JY9516
  • AIAnalogTriggerComparator : JY9516
  • AIAnalogTriggerEdge : JY9516
  • AIAnalogTriggerSource : JY9516
  • AIAnalogWindowCondition : JY9516
  • AIDigitalTriggerEdge : JY9516
  • AIDigitalTriggerSource : JY9516
  • AIMode : JY9516
  • AIRange : JY9516
  • AISignalExportSource : JY9516
  • AITriggerMode : JY9516
  • AITriggerType : JY9516
  • ChoppingFrequency : JY9516
  • Coupling : JY9516
  • FilterMode : JY9516
  • IEPEConnectionStatus : JY9516
  • SamplingState : JY9516
  • SignalExportDestination : JY9516
  • SyncTopology : JY9516
  • SyncTriggerTerminal : JY9516


9516 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY9516 |
C AIAdvanced | Analog Input Advance Parameter Class
C BesselCompensation | Bessel Compensation Parameters
C AIChannel | AI Channel
C AISignalExport | AI Signal Export Class
C Sync |
C AIDigitalTrigger | AI Digital trigger params
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AITrigger | AI Trigger params
C JY9516AITask | JY9516 AI Task
C ConversionStatus | ADC Convesion Status Class